Impossible to import already deployed server

Hello guys/support
I am using MAAS v3.4.x and release notes for v3.1.x says that it is possible to add already running server via CLI:

How to enlist a machine that’s already running a workload

MAAS | Reference: Release notes MAAS 3.1
In v3.4.2 still there is no option to import already deployed machine. The CLI example mentioned doesn’t work as it adds server to MAAS but “deployed” server after next reboot doesn’t boot into installed OS via boot-disk but it boots under MAAS control via NET so it goes into the ephemeral image!
I tried to disable booting under MAAS control via command which is used after successful deployment: “wget --no-proxy http://IP:5248/MAAS/metadata/latest/by-id/xxxxxx/ --post-data op=netboot_off -O /dev/null” but it doesn’t solve the issue as the server doesn’t boot into existing OS.
Only working solution is to add server as deployed via CLI and then initiate RESCUE MODE, wait to finish and EXIT RESCUE MODE. Now the server with existing workload boot properly via disks but in such case server stays more than hour out of order and e.g. power option is not configured (manual–>IPMI) as done during commissioning.
Is there a working workflow (v3.4.x) how to add already running server to MAAS with correct booting via installed OS and not get stuck in ephemeral image booted via MAAS?
There is also no way how to switch server from e.g. COMMISSIONED state (to detect HW correctly) into DEPLOYED state without reinstalling existing OS. Modifying database directly is a no-go.
Thank you very much for any hints provided.

Hi @temp0, could you share the command you used to create the machine?

By design the machines must always PXE first. MAAS will then decide what to do with the machine depending on the status of the machine.
By @r00ta

Ideally, the machine will be booted into the 1st boot option (PXE), check whether jump to the 2nd boot option, or load the ephemeral OS into memory for disk wiping, OS installation or commissioning.

Since you are stuck at the ephemeral OS, it might be an issue with the workflow. Ideally, you don’t need to disable the netboot.

Hi @wyattrees
As stated in the release notes:

maas $profile machines create deployed=true hostname=mymachine architecture=amd64 
mac_addresses=00:16:3e:df:35:bb power_type=manual

There is no change when adding commission=false/true, removing power_type, etc., still machine is added as DEPLOYED but next reboot it tries to commission machine so it is PXE booted instead of booting from disk.

Hi @maasuser1
I tried many different options, also without trying to disable netboot manually to force MAAS booting server via installed OS (from disk) but without success.
I understand that server will try to boot via PXE under MAAS control but MAAS should send crafted grub.cfg file to boot from disk and skipping booting to the ephemeral image as it does after successful deployment. Release notes describe option to add already running workload without wiping it or reinstalling it during new deployment but it doesn’t work like that when next restart will not boot installed OS and will stuck in ephemeral image/in enlisting/commisioning/grub rescue mode/…

Could you open a bug on launchpad?