How to disable dhcpd6 on maas?

I just want dhcp work in the ipv4 environment.
It looks like ipv6 is causing the dhcpd logs.I dont need dhcpd6 although I do have an ipv6 address on the rackd.

Hi @maristelsk,

you can disable the DHCPv6 in the subnets you want, using either the UI (turn off managed allocation in the subnet settings) or using the CLI:

maas $ADMIN subnet update $SUBNET_ID managed=false

Unfortunately there’s a bug here and MAAS won’t rewrite the dhcpd config if you change this property only. You need to flap another key to make this effective, for example:

maas $ADMIN subnet update $SUBNET_ID managed=false,allow_dns=false
maas $ADMIN subnet update $SUBNET_ID allow_dns=true
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.