Help configuring MaaS system with DHCP


#1

I have a few old Intel NUC computers so I decided to try to set them up with MaaS, but I’m a bit out of my element with the setup and I’m hoping someone can help me out. My ultimate goal is to set up a Kubernetes cluster to use for scaling up CI builds and get some experience with cloud computing concepts.

Hardware-wise, I have the following:

  • An Intel NUC8i7BEH with Ubuntu Desktop 18.04 (“manager”)
  • A few Intel NUC5i5RYH’s to serve as the nodes. I configured them for network PXE boot.

I connected the network components as follows:

  • Manager computer connected to home router via ethernet. Set a static IP address of 192.168.1.18. Interface is enp0s31f6.
  • USB3-to-Ethernet dongle out of manager computer to basic 8-port network switch. Interface is enxd8eb97b3e376, but it does not have an IP address.
  • Node computers connected by ethernet to network switch.
  • I still have the node computers powered off.

I installed maas as a snap and did the basic configuration on command line and web interface (all defaults, included launchpad ssh key). I was surprised that even though it seems like MaaS is idle I have one core of my CPU consistently maxed out, but I’m guessing it’s not relevant to my current problem.

I tried to follow the directions here (https://maas.io/install, step 6) to setup DHCP. This instruction says to select the VLAN you want to enable DHCP for, select “take action,” and then “provide dhcp.” When I get to this step there is a dialog box titled “Default VLAN in fabric-2.” The first entry item is a dropdown menu saying “Rack controller.” However, there is nothing for me to select here (just an empty menu).

Here is a screenshot of my controller interfaces summary page, if it’s helpful:

When I go to the “Nodes” menu and then “controllers,” I see I have a region controller named “ghost.maas.” If I click on it and then go to the configuration edit page, I see an error message: “Editing is currently disabled because no rack controller is current connected to the region.” I’m not sure how to connect a rack controller to the region, and I’m also not sure how to configure my network setup and subnets.

I’ve tried a lot of searching but haven’t come across others with my situation. Do I have something wrong with my configuration? Was I supposed to do some network setup before installing Maas? I would appreciate any help anyone is willing to offer, and I apologize if this is the wrong type of topic for this forum.

Ted


#2

I think you’ll need to assign an IP address to your enxd8eb97b3e376 interface in order to use it to provide DHCP, and then it will be selected by default in the list of rack controllers (when you go to provide DHCP). Having an IP address is a requirement for the DHCP protocol to operate, since DHCP uses UDP over IP in order to assign addresses. (Counter-intuitive, I know, since the clients won’t have an IP address to begin with!)


#3

Thanks @mpontillo! That did the trick for me and after that getting MAAS setup was pretty straightforward. Sorry it took me a while to get back to you, I had some trouble setting up my static IP and had to track someone down to fix it for me (as always, one little thing wrong in the configuration file and nothing works).