Grub error


#1

setparams ‘Commission’
echo ‘Booting under MAAS direction…’
linux ubuntu///bionic/no-such-image/boot-kernel nomodeset ro root=squash:http//10.0.0.1:5248/images/ubuntu///bionic/no-such-image/squashfs ip=::::BMC3:BOOTIF ip6=off overlayroot=tmpfs overlayroot_cfgdisk=disabled cc:{‘datasource_list’: [‘MAAS’]}end_cc cloud-config-url=http://10.0.0.1:5248/MAAS/metadata/latest/by-id/xfed48/?op=get_preseed apparmor=0 log_host=10.0.0.1 log_port=5247 BOOTIF=01-${net_default_mac}
initrd ubuntu///bionic/no-such-image/boot-initrd

So, we get this error when booting one of our machines under maas direction.
also:
error: File not found
error: you need to load the kernel first

Anyone seen these problems before?

Edit: also: Failed to boot both default and fallback


#2

Make sure Bionic is selected on the images page and that all rack controllers have been synced.


#3

pretty sure all that is true

Thing is: One of our machines commissioned, and the other got this message, so I think the problem is on the machine that will not commission


#4

Can you go to the specific machine and check what’s the setting for ‘Minimum kernel’ ?


#5

We have set ‘No minimum kernel’ across the board.
But it does not show up in machines yet, since this is the ‘first’ boot to make maas aquire it