Getting Read-only file system error during maas backup

I am trying to backup my maas setup(maas version 3.3 snap), for that I am following this link How to backup/restore maas for maas version 3.2 snap cause I was unable to find any documentation on 3.3. I was able to get configuration files and db dump from my maas setup.

I did a fresh maas installation on another machine but while restoring when I ran
sudo mv /snap/maas/current/etc/maas /snap/maas/current/etc/_maas
I got this read-only file system error
mv: cannot move '/snap/maas/current/etc/maas' to '/snap/maas/current/etc/_maas': Read-only file system
Has anyone faced the same error, is this error due to version difference (I am using latest 3.3 beta and following backup/restore doc for 3.2 snap) or am I missing anything else?
Any help will be appreciated.

@lovekush-sharma, i’m actually not sure those instructions are necessary, and they’re broken anyway. snap is an RO filesystem, you’d have to remount it as RW to do that, and you don’t want to remount it… there’s nothing in /snap/maas that you can actually back up. you should instead use sudo snap save maas as shown here, noting the snapshot number, and then restore that snapshot by number to your newly installed machine.

sorry those instructions are so broken; i’m going to go fix that right now. to be clear, you still back up and .tgz the DB, but you let snap save do the rest of it, then sudo snap export-snapshot <snapshot-id> my-snapshot, copy my-snapshot to some external media, go to the new snap install and do the snap restore on <snapshot-id>. like i said, i’m diving in now to fix those instructions, so maybe they’ll be right by the time you read this.

1 Like

@lovekush-sharma, okay, the article is fixed. let us know if you can’t get your backups working right and we’ll try to help.