Getting HTTP 404 reponse when I try to login to API


I am geting a HTTP 404 when I try to login to the MAAS API:

maas apikey --username=maasuser

xxxxx:xxxxxx:xxxxxxx (real API KEY omitted)

maas login admin

API key (leave empty for anonymous access):
The MAAS server gave an unexpected response: 404

This was working and I used many times when I needed to import a boot resource (image)

Also when I list the remote API’s , I get an empty list , not sure why because it provides me an API key with the ‘maas apikey’ command.

maas list

Usually I get the URL & apikey as a response.

Any idea what could be wrong here ?

Hi @nhermans

Shouldn’t it be maas login admin
Also what is your MAAS version and is there anything interesting in the nginx/regiond logs?

Hi @troyanov ,
Thanks for your answer ! I was always using /api/2.0/ as login, but when I tried /MAAS path, it worked well. So the thing I missed was the /MAAS/ , sorry I missed that !
Many thanks for spotting this out !
Kind regards,

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.