Forcing GPT Boot Disk / Working Around Boot Order Issues


#1

I’m running in to the issue described here on the mailing list last year. With a BIOS/Legacy boot, the wrong drive is booted from - causing the boot to hang on the “WARN: No MBR magic, treating disk as raw.” error described in bug 1671605. On some HP systems this also causes a more serious OpCode error red screen of death.

Bug 1737464, which relates directly to the bug discussed on the mailing list appears to still be a work in progress. In the meantime it sounds like the issue does not occur when the boot disk uses a GPT partition table instead of a MBR one - as presumably the boot would be via an explicit GPT ID rather than the “_x_th drive”, which may or may not be the correct one in the PXE environment? However, GPT partition tables are seemingly only used when the boot disk is over 2TB, otherwise MBR is used and there is no apparent option in the MAAS UI to override this.

Is there any way to force boot disks <2TB to use a GPT partition table?


#2

I just did this by disabling BIOS and enabling EFI (everywhere I could).

I’ll post more details later on…


#3

When i’ve booted via UEFI, GPT has always been selected by default and has worked excellently. Unfortunately, I have a few older machines that are either BIOS boot only or don’t support UEFI network booting alas.


#4

I’m also seeing a need to use GPT (plus 1MiB bios_grub partition) with BIOS (not EFI) on devices < 2T. I’m tired of MBR, honestly.

Would be awesome to select the partition type from MaaS UI!

BIOS booting GPT looks cool.


#5

I too have servers that cannot EFI boot, no magic MBR is becoming the bane of my existence. Has anyone found a way to force a <2TB drive to use GPT? The last thing I want is to have to splurge on 3TB drives just for the OS