Failed deployment

Hello all,
I’m running into an issue deploying a brand new HPE server.
Here are the details:
HPE ProLiant DL360 Gen10
MAAS version: 2.3.5 (6511-gf466fdb-0ubuntu1)

Here is the installation output:
curtin: Installation started. (18.1-17-gae48e86f-0ubuntu1~16.04.1)
third party drivers not installed or necessary.
no disk with serial ‘600508b1001c59884c2226fdc7b0c2db’ found
curtin: Installation failed with exception: Unexpected error while running command.
Command: [‘curtin’, ‘block-meta’, ‘custom’]
Exit code: 3
Reason: -
Stdout: no disk with serial ‘600508b1001c59884c2226fdc7b0c2db’ found

Stderr: ‘’

Commissioning worked with Ubuntu 18.04 LTS - one of the ways I was trying to resolve this issue was by adding badblocks-destructive hardware test (found recommendation online).

Another way I was trying to resolve it was by adding general kernel parameters:
cciss.blacklist=yes modprobe.blacklist=cciss hpsa.hpsa_allow_any=1 hpsa.hpsa_simple_mode=1

Didn’t help.

I tried many time but its not working.

Am I missing something? any ideas how to resolve this?


Looks like it wasn’t working because the virtual nic was enabled on the iLo, we are now able to deploy the server.

1 Like