Failed deployment on SAN boot ESXi 7 server


I tried to deploy ESXi 7.0 U2 custom image with MAAS 2.9.2 (9165-g.c3e7848d1) onto HPE DL360 Gen9 server. This server has not got any local boot disks. Boot disks comes from SAN storage with 4 path.
Commision just fine but when I tried to deploy it Failed with this error:

finish: cmd-install/stage-partitioning/builtin/cmd-block-meta: FAIL: curtin command block-meta
        Traceback (most recent call last):
          File "/curtin/curtin/commands/", line 202, in main
            ret = args.func(args)
          File "/curtin/curtin/", line 97, in wrapper
            return log_time("TIMED %s: " % msg, func, *args, **kwargs)
          File "/curtin/curtin/", line 79, in log_time
            return func(*args, **kwargs)
          File "/curtin/curtin/commands/", line 107, in block_meta
            return meta_simple(args)
          File "/curtin/curtin/commands/", line 2023, in meta_simple
            raise Exception("target device '%s' is not a valid device" % target)
        Exception: target device '/dev/mapper/mpatha' is not a valid device
        target device '/dev/mapper/mpatha' is not a valid device

Is MAAS support ESX deployment like this?
If you need any other information, just let me know.
Thank you.


@laszlolaszlo80, does this doc help you at all?

I read that documentation and I created the correct esxi image as well.
I think the deployment process is not support SAN boot LUN-s with multipath yet.
That’s why I examine VMware Autodeploy function. It is working well.

1 Like

if you’d like to have SAN boot LUN-s with multipath considered (no promises), you can add it to the Features category on discourse. if you’re happy with what you got, hey, glad you found a solution!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.