Error: Node must be connected to a network

Hi all. I’m new to using MAAS and getting close, but it seems I’m stuck. I’m deploying it using this guide specifically for deploying to Raspberry Pis using this guide:

So MAAS has been installed through snap, along with the demo db, and I have access to the UI, on a 192.168.5.x IP. MAAS will be managing a subnet So I created that .7.x subnet manually and hit save. Now it’s warning me that I need to setup DHCP, ok. I click on the “Untagged” label under VLAN, then “Configure VLAN”. It defaults to “MAAS provides DHCP” as enabled and to provide DHCP from rack controller(s). Everything looks good, but the “Configure DHCP” button is greyed out and I can’t click due an error “This VLAN is not currently being utilised on any rack controller.”

Ok… so googling around, it sounds like I need to click on “Controllers” in the main menu and the controller name. I click on the VLANs sub-menu for this node, nothing. The “Take Action” button just lets me delete the controller. So I click on the “Network” sub-menu for the node, nothing. I only have the error “Error: Node must be connected to a network.” Ok… I click on “Take Action”, nothing, just a delete button again.

So now what? Does my Controller need to be on the same subnet as the target DHCP subnet? How come Network Discovery isn’t doing anything? Can I help it along with some suggestions via the command line?

Any update on this? I’ve been playing around with the command line and still don’t spy an easy way to connect the region/rack controller to a network.

I tried to see if it’s something you can do at init with maas init region+rack --help but nothing.

I verified network discovery was active with maas admin maas get-config name=network_discovery and it returns

Machine-readable output follows:

I really liked the look of this command maas admin network connect-macs but it reports This endpoint is no longer available. Use the 'subnet' endpoint instead.

Ok… looking at the help for that, doesn’t look like there’s an equivalent functionality. With maas admin subnet --help we get

drill down:
    delete              Delete a subnet
    ip-addresses        Summary of IP addresses
    read                Get a subnet
    reserved-ip-ranges  List reserved IP ranges
    statistics          Get subnet statistics
                        List unreserved IP ranges
    update              Update a subnet

Finally, I was looking at the interface command, which lets you add an interface to a node. So I assumed that would work for a controller but when I run maas admin interfaces create-physical k76634 mac_address=00:00:00:00:00:00 vlan=0 it returns Cannot create interface on a controller

My network seems like it should be trivial to map since it’s currently just 3 subnets, no VLANs, all going back to same opnSense Router with almost entirely open firewalls between them.

@mcdeltat, this is a tricky one, not trivial to find. i’ll look at it this week. i guess i finally need to try the rPi4 setup, maybe.

@mcdeltat, oh, wait a minute: when you tried to Configure DHCP, did you remember to choose the rack controller from the dropdown menu on that form?