Does MAAS Snap use internal VLANs for untagged frabric?

Installed the Snap, each fabric is untagged, 1 network per fabric, I turn on dhcp for an untagged VLAN int enp59s0f0 that has the correct IP for the subnet and this is what gets into dhcp.conf:

shared-network vlan-5006 {
subnet netmask {
ignore-client-uids true;
option subnet-mask;
option broadcast-address;
option domain-name-servers;
option domain-name “maas”;
option domain-search “maas”;
option ntp-servers;
# Bootloaders

What is that “shared-network vlan-5006”?

The UEFI PXE request get sent from the machine to the interface as seen with tcpdump, but no reply is ever given from MAAS…

Thank you

My experience with the API and the CLI tools, is yes, untagged VLANs are still implemented as VLANs conceptually, but it doesn’t really mean that much in terms of the dhcpd.

Do you have a dynamic range setup in the subnet, or a static assignment set for the host? Does the dhcpd report ever mention the incoming MAC?

Thank you for you answer.

The issue was actually that when deploying MAAS Snap version, all interfaces on the Rack + Region Controller must be configured prior to installing and initialising MAAS Snap.

MAAS seems unable to refresh the configurations of the interfaces of the Controller if IP address is assigned after init. Whether you reboot, refresh or any command I tried, I have to purge the database and re-init clean with all interfaces configured for DHCP to be able to work.

1 Like

@luclemieux what version of the snap are you running?

Could you please check logs (especially regiond.log and rackd.log for errors?

MAAS should periodically report and update discovered networks, if it doesn’t, there’s probably an error processing the information.

2.9.2 and I have now switched to "candidate> branch to have a fix for Python API which prevented some calls to be processed by the HTTP handler because of a dependency that is now upgraded in candidate.

sudo snap install maas --candidate

The Snap seems very unstable on multiple fronts, the network interfaces never seem to update as mentioned previously and most of the time some rackd services go down and never come back up even after reboot.

Last week had rackd, httpd, tftpd and dhcpd go down and was never able to get them back up. Had to snap remove maas and mass-test-db and re-install the whole thing. Even just purging the DB and re-installing mass-test-db with a re-init region+rack came back with the services still dead.

I am on Ubuntu 20.10 Groovy and tried to add the APT repo “sudo add-apt-repository” which contains “InRelease” for Groovy, but was never able to install production MAAS with “yum install maas”

Thank you

Can you please check if you also have maas-related packages installed via deb (e.g. via dpkg -l | grep maas).
if you have both a snap-based and a deb-based maas running, they’ll conflict and cause issues

1 Like

Running “dpkg -l | grep maas” returns nothing.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.