Does MAAS 2.7 support PXE port bonding?

I have a Question. Does MAAS 2.7 support PXE port bonding?

I have a problem that the ubuntu does not boot normally on the server with Bonding.

However, it occasional boots up.

Regards,
Yohei

What type of bond ? You mean LACP ?
I doubt your server starts with a bond, it first boot from a single port interface then, once your OS is booting, the bond is setup but you don’t PXE boot on a bond.

Thank you quick reply.
Currently it is balance-alb.

That doesn’t change anything in the PXE boot process … when starting in PXE, your server will send a dhcp request on a single interface port and will receive an answer from MaaS with the pxe configuration 'basically, an URL where your server will find a base image to boot from) then, once booted, MaaS will send command lines and configuration options to your server through cloud-init to configure your networking and a few other things like your storage layout for the OS installation.
Then, once installed, your server will reboot and switch from pxe boot to local hard drive boot with your new OS installed and configured (and this is at that time that your bond should be configured).

If it is not working as it should, you should first check your network stack (switches, interfaces, cabling, …)

Try with active-passive bonding first (or even, no bonding) to see if it works.

I’ll give it a try. Thank you.

After commissioning the node with MAAS, we set up bonding.

After that, when I deploy or release by Erase disks, it stops at GRUB screen.

However, ubuntu sometimes works.

You may be experiencing an issue similar to https://bugs.launchpad.net/maas/+bug/1437353 with regard to the bare grub prompt at boot. We’ve found the workaround is to type “exit” at the grub prompt and then select in your bios to continue with normal boot.

We’ve also seen this on other intel 10+GB cards, not just the one listed in that bug report.

1 Like