DHCP issues when commission new system

I tried to commission a new system with MAAS 2.6 lately. However, I noticed that my secondary rack controller was having dhcp issues. The maas-dhcpd was not running due to missing /var/lib/maas/dhcpd.conf.

I disabled DHCP service from fabric-0 (MAAS) and try to enable it. But it keep on saying that my secondary rackd is having issue. I removed secondary rackd server from MAAS and I confirmed that no DHCP is running on it. (and no ISC-dhcp as well).

I then tried to re-enabled DHCP service on fabric-0 (MAAS) on primary rackd server. I got the following error.

I am sure there is no DHCPd running on my secondary servers ( I verified it with ps and netstat (port 67,68).

Is it because of network entry in Postgresql that is causing this problem? How do I fix that?

How do I unset external_dhcp?

root@nm-203-31:~# maas admin vlan update MAAS untagged external_dhcp=null
Machine-readable output follows:
“vid”: 0,
“mtu”: 1500,
“dhcp_on”: false,
“external_dhcp”: “”,
“relay_vlan”: null,
“fabric”: “MAAS”,
“space”: “undefined”,
“fabric_id”: 0,
“secondary_rack”: null,
“primary_rack”: null,
“name”: “untagged”,
“id”: 5001,
“resource_uri”: “/MAAS/api/2.0/vlans/5001/”