Deployed node has no internet access, network problem


I have a test setup for Maas which I want to use in production.
This setup came after many iterations, every setup before, the nodes had internet access.

The diagram shows a small part. I came to this setup to isolate racks and have smaller sub-nets.

Layer 1 has only 1 25GbE card per regiond, rackd and nodes, switches use vni/vlan to tie everything together. Thus IPMI is sideband on the NIC. I use a vlan id on the IPMI to isolate traffic from the PXE network.

  • Since I only have 1 NIC and I keep PXE boot untagged the rackd’s are connected to the regiond over a vlan (105).
  • The untagged nic on rackd is in the nodes subnet
  • vlan id 4000 is used for IPMI traffic to the rackd
  • The MNGT subnet ( needs to access all rackd node’s IPMI for some management tasks
  • I created gateway’s on PFsense to reach and from
  • is Fabric-0 in Maas
  • All other networks are Fabric-1, this was automatically done by Maas

Adding nodes in Maas works perfect, just power on (IPMI vlan id is set beforehand) and the appear in Maas, commission and deploy, all fine. However, after deployment I don’t have internet access, nor can the commission scripts reach

I expected to have internet access, since networking is not my strong suite I tried to narrow it down with tracepath and ping, it seems that rackd is not forwarding between subnets how I expected it

  • Proxy access on the node subnet is on
  • Node can ping
  • Node cannot ping or any other IP on this subnet besides
  • Rackd ( can ping public IP’s and fine
  • Other way around, can ping Rackd on, but not a node
  • I tried adding Fabric-1 subnets in a single space, no change
  • I tried setting the kernel ip_forward bit to 1 on Rackd, no change

Why is rackd not forwarding the packages?


This morning everything started working fine, at the moment I’m not sure why.
I will leave this post here in case somebody has any insight or remark about the setup.


1 Like