Deploy ESXi on server with more then one disk

Hello.

When I deploy server with only one disk in it everything works fine. But on servers with two or more disks MAAS don’t create any datastores. It successfully deploy ESXi, configure network, register server in the vCenter. But there are no any datastores. I tried to create datastores in UI on both disks, tried leave datastore only on the disk with the system. In both cases there no datastores after deployment. And only when I deleted second disk in the UI, after comissioning, server succsessfully deploed and created datastore.

Also I can’t choose disk to setup ESXi. In logs I see that maas chose disk by itself

Running command [’/usr/sbin/multipath’, ‘-F’] with allowed return codes [0, 1] (capture=False)
‘custom’ mode but multiple devices given. using first found
mode is ‘custom’. multiple devices given. using ‘/dev/sda’ (first available)
installing in ‘custom’ mode to ‘sda’
writing image to disk {‘type’: ‘dd-gz’, ‘uri’: ‘http://10.15.30.30:5248/images/esxi/amd64/generic/7.0.2-ams/uploaded/root-dd.gz’}, sda

Is it possible to deploy ESXi on servers with more then one disk?