Deploy does seem to allow editing of sshd_config

Using the packer-maas rhel8 kickstart file, I add a line to the %post to edit the sshd_config file.

sed -i -e 's/^PasswordAuthentication no/PasswordAuthentication yes/g’ /etc/ssh/sshd_config*

This command works from the command line. But when MaaS deploys the image created with this kickstart file, the setting never takes effect. Maybe MaaS is doing something later to force no password authentication? is that part of curtin? how do I edit what MaaS during and after deploy?

Also, I see from installing RHEL that the default is PasswordAuthentication yes. so MaaS is interfering with this. Canonical’s idea of security is interfering with me running my lab. Canonical needs to post more detailed documentation on how to control this system.