Dell Perc H750 RAID adapter not found

We recently received some new Dell R640s and they have a newer generation of PERC raid controller. According to Dell, 20.04 is the first ubuntu release to support this controller. I have verified that booting to an 18.04 live CD does not see any storage, but the 20.04 installer ISO does see it.

I upgraded my maas server to 20.04 and upgraded maas to 3.1. But when I enlist and commission any of these machines, maas sees no storage whatsoever. Any ideas?

Edit: I also tried syncing the latest 20.04 image, but it’s stuck at “Waiting for rack controller(s) to sync” forever. Even after rebooting the maas server it’s still waiting for them to sync. So something is clearly broken.

hi, @mrwboilers,

I see your point, that does sound a bit weird.

Can you send us some information?

Identify your version and build

We need to know the version and build (and packaging format) that you’re running. You mentioned 3.1, but we need a little more information.

If you’re using a snap

If you’re using a snap, execute snap listmaas at the command line, which will return some lines like this:

Name  Version                       Rev    Tracking     Publisher   Notes
maas  3.0.0~beta2-9796-g.2182ab55f  13292  latest/edge  canonical✓  -

Please add the output of that command to a comment on this post.

If you’re using a Debian package

If you’re using a deb, execute apt list maas at the command line, and enter whatever it returns into a comment to this post, as in the snap example above.

Using CLI, UI, or API?

Next, you’ll need to specify which interface you’re using, and generally what command(s) you were attempting.

Explain what happens

Being as concise and specific as you can, please explain a little more about what seemed to go wrong. You mentioned that commissioned machines don’t show any storage. You also mentioned that you can “unstick” the controllers from waiting for a rack controller sync. Can you show us some screenshots of the machines that commission with no storage, for example?

Explain how to reproduce your issue

In addition to the explanation above, you should create a step-by-step list of what you did to reproduce the problem. Sounds like it’s pretty simple – just try to commission a machine – but we’d like to be sure.

Take relevant screenshots

If you think it will help – especially when using the UI – try and capture screenshots of any unexpected results or ambiguous actions. Your goal isn’t to document your experience in pictures, but to provide a visual reference where verbal descriptions fall short. Name these so you can sync them with your explanation (e.g., “screenshot-1”). You can just upload them into your comment.

Locate and capture logfiles

If at all possible, capture at least the following logfiles, for the time period surrounding your error situation:

  1. maas.log
  2. regiond.log
  3. rackd.log
  4. the rsyslog file of the affected machine(s), if it exists.

On snap, these files are located as follows:

  • /var/snap/maas/common/log/maas.log
  • /var/snap/maas/common/log/regiond.log
  • /var/snap/maas/common/log/rackd.log
  • /var/snap/maas/common/log/rsyslog/$MACHINE_NAME/$RELEVANT_DATE/messages

If you’re using packages, you’ll find the files in these locations:

  • /var/log/maas/maas.log
  • /var/log/maas/regiond.log
  • /var/log/maas/rackd.log
  • /var/log/maas/rsyslog/$MACHINE_NAME/$RELEVANT_DATE/messages

Ideally, you’d want to put these in a pastebin and link the pastebin location in your comment.

Thanks for this. We’ll need this additional information in order to try and figure out what’s going on.

Maas version:
maas 3.1.0-10901-g.f1f8f1505 18199 3.1/stable canonical✓ -

I PXE boot the machine to enlist it. After that I commission it. I remove the smartctl-validate test when commissioning. This is through the GUI. After commissioning, it has no storage info. It just doesn’t recognize the RAID controller (screen shot 1)

maas.log: https://pastebin.com/15r6mFyv
regiond.log: https://pastebin.com/eAQD4Rhf

It won’t let me post more than 1 screen shot and 2 links per post.

The image sync issue is something completely separate. In a bit of desperation, I tried syncing images in case that would somehow help the RAID controller issue. That was at least 2 weeks ago, and it still says it’s syncing.

Here is the other requested log:

rackd.log: https://pastebin.com/yz0VcHWa
Nothing with the generated hostname in /var/log/maas/rsyslog

okay, now we can see that the commissioning scripts fail when you use the embedded switch. can you get us the commissioning script logs around the failure?

Check that you have a Virtual Disk configured in the controller. That solved my issue.

1 Like

thanks @dweeks75080. nice.

@billwear I was out a couple days last week. I’ll try to get the commissioning logs today

1 Like

Actually, I’m not sure how to gather the commissioning logs? I don’t see a way to do that in the gui. Do I need to grab it from the cli? I don’t see a messages.bz2 with today’s date. Most recent is from march 1.

if you go to the machine, there’s a tab there that will let you view the commissioning logs. you can then copy-paste those to a pastebin somewhere.

All I see is this, unless you want the machine output (in yaml or json)

Oh, and it already has a virtual disk configured

Hi,

the last screenshot shows that some Tests failed. Can you access this tab, and get the output of the failed tests (in actions > view details)?

Also go to Settings > Configuration > Commissioning and check the Default Ubuntu release used for commissioning. If you have upgraded MAAS from a previous version you might still be using Bionic for commissioning

The default release for commissioning was still set to bionic. So I changed it to focal. I was hopeful that would get me going. But so far no luck. I re-commissioned the machine and it still didn’t see any disks.

So, I deleted the machine to start fresh. After enrolling the machine, commissioning is all pending and I can’t seem to be able to do anything.

D’oh. I had to abort that commissioning. Now I’m able to run commissioning on it. I’ll let you know how that goes.

No luck. All the commissioning scripts just come back aborted, and with no returned data.

Can you show me the logs from /var/snap/maas/common/log/rsyslog/maas-enlisting-node ?

Trying to post a pastebin link to maas-enlisting-node, but it’s telling me I can’t post links

My posts have been marked as spam for some reason. No idea why.

ok, let’s try this again. Here’s maas-enlisting-node: https://pastebin.com/bYBmV7Xx