Convert network type "Bridge" to "Open vSwitch Bridge" on deployed node with OpenStack

Hi folks,

Using MAAS 3.1, have deployed Charmed OpenStack (focal-xena) on 5 physcial hosts, I have deployed a host with a bridge of “type” physical (br-ex) on the only network interface (appears as type “Bridged Physical” on MAAS GUI). However the rest of the hosts are deployed as “Open vSwitch” (br-ex). The host with “Physical” has lxd containers and services running on it, such as ceph-mon etc.

The host is reachable on the network and its lxd container services all seemingly work, but
a.) I would like to convert this node to “Open vSwitch” like the others
b.) I have errors when I do “ovs-vsctl show” on the host with the Physical Bridge -->
" Port br-ex
Interface br-ex
type: internal
error: “could not add network device br-ex to ofproto (File exists)”

Any ideas what the best way to fix this and to have the reality reflected in MAAS GUI as well?

I have 2 ways I can think of:

  1. Move the services off that host and fix the “Bridge” type in MAAS and redeploy just that host?
  2. Manually convert the host to “Open vSwtich Bridge” and just live with the host being wrong in MAAS?


If it was a fresh install, I would probably go with option 1 if it was that big of a deal for you. You could always use your configuration scripts to setup the node how it was. (It would also be good practice in case you had a node go dead during production.)

I haven’t tried this myself (just thinking out loud) you could do is edit the netplan on the node to switch it to use OVS for that bridge. I would use one of the other nodes as a reference for how maas deployed it. Then on MAAS 3.2, they added the hardware sync feature so if it is possible for you to upgrade your maas install, you could try that to see if the change is reflected in maas. Worse case scenario you just have a special snowflake system that looks different in maas but functions the same as your other machines. You could tag that node with a description to remind yourself of this difference in the future. Hope that helps!

@duibhneach, did you try @ben-ihelputech’s suggestion?