Commissioning failure with 20-maas-01-install-lldpd getting 404s downloading packages

We’re having a problem commissioning new systems in MaaS 3.2.6 … the 20-maas-01-install-lldpd script fails. It’s getting 404’s trying to download certain packages. What’s weird is that it’s trying to download old packages. It’s like the depsolver is selecting the wrong packages. Newer packages exist… yet, it’s trying to grab older ones.

Reading package lists...
Building dependency tree...
Reading state information...
The following package was automatically installed and is no longer required:
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libevent-2.1-7 libsensors-config libsensors5 libsnmp-base libsnmp40
Suggested packages:
  lm-sensors snmp-mibs-downloader snmpd
The following NEW packages will be installed:
  libevent-2.1-7 libsensors-config libsensors5 libsnmp-base libsnmp40 lldpd
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 1643 kB of archives.
After this operation, 5683 kB of additional disk space will be used.
Get:1 jammy/main amd64 libevent-2.1-7 amd64 2.1.12-stable-1build3 [148 kB]
Get:2 jammy/main amd64 libsensors-config all 1:3.6.0-7ubuntu1 [5274 B]
Get:3 jammy/main amd64 libsensors5 amd64 1:3.6.0-7ubuntu1 [26.3 kB]
Err:4 jammy-updates/main amd64 libsnmp-base all 5.9.1+dfsg-1ubuntu2.2
  404  Not Found [IP: 80]
Err:5 jammy-updates/main amd64 libsnmp40 amd64 5.9.1+dfsg-1ubuntu2.2
  404  Not Found [IP: 80]
Get:6 jammy/universe amd64 lldpd amd64 1.0.13-1 [193 kB]
Fetched 373 kB in 1s (638 kB/s)
E: Failed to fetch  404  Not Found [IP: 80]
E: Failed to fetch  404  Not Found [IP: 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

When I look for the failing packages… they don’t exist… yet, newer/other versions are available. What makes the depsolver choose these wrong packages?

I’m experiencing something similiar MAAS version 3.1.0-10901-g.f1f8f1505. This causes the commissioning process to fail.

Experiencing the same behavior with MaaS 3.2.6, tried commissioning with 18.04, 20.04, 22.04 all the same result.
Worked around the issue by creating a commissioning script with the following contents

sudo apt-get update

If you don’t want to use a custom commissioning script:

  • change the default commissioning image to Jammy
  • change the default Ubuntu package repo a different mirror

@thomsley, i daresay this is the solution. not downloading the LLPD stuff is a sign of connectivity issues, usually. i’m going to treat your suggestion as the solution, but @aspeagle, @cmills, @sjtanner – if you don’t agree – repost / reopen at will.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.