Commissioning Controller Failing


I’m having trouble getting my controller to commission to MAAS. Fairly simple setup, just a single Ubuntu 20.04 box running a region+rack controller. I’ve tried it both with a postgres docker container and the maas-test-db with the same results. I’m running snap version/build 3.1.0-10901-g.f1f8f1505 19835 and I’ve tried using both the UI and the CLI.

It appears to be failing on the 50-maas-01-commissioning script. The STDOUT of the script looks right. But I get an error about a string literal with NUL (0x00) characters in the regiond.log

Here’s the end of the error:
File "/snap/maas/19835/usr/lib/python3/dist-packages/django/db/backends/", line 84, in _execute return self.cursor.execute(sql, params) builtins.ValueError: A string literal cannot contain NUL (0x00) characters.

And the full regiond.log:

The Controllers tab shows a green check like everything is good,
…but under the Commissioning tab, it shows a Failed:

STDOUT has the output of the script, but STDERR just says Empty file.

My steps to set MAAS up are as follows:

/snap/bin/maas init region+rack --database-uri postgres://maascli:<db_pass>@localhost/maasclidb --maas-url http://<IP>:5240/MAAS

– OR –

/snap/bin/maas init region+rack --database-uri maas-test-db:/// --maas-url http://<IP>:5240/MAAS

/snap/bin/maas createadmin --username <admin_user> --password '<admin_pass>' --email <admin_email> --ssh-import gh:<user>

And then logging in, going through the setup, and clicking on the Controllers tab.

I had other screenshots and links to logs here - hopefully I can add them in comments.

I’ve had a coworker who also runs MAAS walking through it with me and neither of us can figure out the cause of this failure so… any help would be greatly appreciated!


Additional logs:



STDOUT of the script - so it’s clearly getting run:

(sorry, I can only do one screenshot at a time apparently)

But it means that no information about the controller shows up on the page… and then of course it can’t be configured as a DHCP server or… anything else.

Hopefully those help!