CloudInit fails due to duplicate mac found in configuration?

Hi,

I recently had to delete and recommission two servers and now both servers are failing to enlist.
The servers were configured with two bonded interfaces before and somehow that seems to be persisted somewhere.
I think that leads to the error I captured from the initial pxe boot. He tries to start the interfaces with the initial config, but fail due to the duplicate mac. I have no idea where to fix this. The servers where deleted through the webinterface.
I tried to purge the maas components via apt purge, but that did not do any change.

I would really appreciate any hint on this.

Kind regards
Benjamin

I enabled the local login in the image and the pxe image boots with the duplicate mac address. I have no idea where that configuration comes from. I tried to change the mac address of the second interface to its default one but it does not survive the next boot.
I do not know if the wrong configuration gets pulled from maas or is persisted at some other point.

Kind Regards

I got a little further. I updated the driver of the network card and now it show a virtual mac in the bios. I have no idea how to delete this and how maas did set it.