Chicken and egg problem setting the power configuration "power address" (IP)

Hi,

I am using MAAS 3.1 and I can’t seem to figure out how to set the Power Address IP without it getting out of sync with what the MAAS DHCP allocates and reserves.

I noticed for example that if I commission more than once, the DHCP address changes and I would have to go to the Power management menu and edit the Power Address according to what the DHCP decided to allocate.

Then I tried to go from Commission to Acquire to Deploy. For Commission and Acquire the IP had not changed. When I got to Deploy, the DHCP IP had changed again and no longer matches the Power Address.

What are the best practices at this step if using DHCP addresses?

Thanks

Chahé

I don’t understand correctly the question.

What type of power drive are you using? Ipmi, redfish, virsh, esxi?

As a general answer, always that need to access a dynamic Ip address you should use a hostname and doesn’t the IP address.

Hi,
I am using the Intel AMT power system.
It requires an IP. Are you saying to put in there the machine hostname instead?

Thanks

m… let my check if I understand.

First of all, I don’t have used Intel AMT , but I thinks that is something similar a BCM but instead of a separated chip/processor is inside the intel processor.

You have MAAS as a DHCP controller in the same network that is the Intel AMT. So the Intel AMT gets its IP address from MAAS.

The main problem, if when you restart or power on the machine, the Intel AMT shutdown, loosing its IP address so when the machine shutdown, it ask for new one.

You have three solutions, use a hostname of the Intel AMT (I don’t know if this is possible setup one), reserve a ip address for the MAC of the Intel AMT or setup a static IP address for the Intel AMT.

As an advise, for management systems it’s better to use a static IP address. And if is possible seppare the Intel AMT network from another different of the machine (Using VLANs, for example)

Thanks adolf094.
For some reason, MAAS DHCP is sending a different IP to the intel AMT vs the OS even though I have a DHCP snippet to fix the IP. The Intel AMT gets a dynamic IP and the OS gets a fixed IP as specified in my Snippet

m… The Intel AMT have the same MAC as the NIC from the OS?

In my experience with Shared iLO Interfaces (HPE iLO uses the same NIC port as the OS), the iLO always have a different MAC Address than the NIC presented to the SO. So always you can set different IP address.

Yes, a single MAC address is used for both.
Part of my problem was traced to somehow my OS having a fixed address configuration in netplan.
So, it was no longer using DHCP and therefore explains some of the issues.
Maybe MAAS could add some documentation explaining what options should not be used.
It is permissive in a way but many allowed config combinations are doomed to fail.

I’m not 100% on this but I believe you could use MAAS as the resolver and use the hostname. Example if I have a host that got given the name “proud-possum” then I can resolve it with “proud-possum.maas” on my testbed:

nslookup proud-possum.maas localhost
Server:		localhost
Address:	127.0.0.1#53

Name:	proud-possum.maas
Address: 192.168.200.19

and if my OoB management lives on that same host/IP, it should work to use that as the power driver address. I don’t have such a machine to test against, but let me know.

1 Like

I will try that, thanks