CentOS 7 Virtual Machine deployments are failing, but Ubuntu is okay (of course lol)


Are you guys deploying CentOS 7 with MaaS 2.5?

I have a fully operational MaaS 2.5 environment, where I can deploy Ubuntu 18.04 on both Real and Virtual Machines.

However, I selected CentOS 7 to sync, it is downloaded / synced but, when I try to deploy it, it fails.

I google about it and it looks like that it’s something related with the fact that CentOS 7 comes with its networks closed by default somehow…

Any idea?


BTW, I noticed that CentOS was installed but, it freezes on its first boot, not finishing the MaaS deployment.

I even tried to use the “CentOS Rescue” at its Grub but, it also freezes. No root login anywhere.

I’ve had similar issue and it was because some packages needed for cloud-init oauth were missing. Put this into your preseed file to a late_command section:

10_install_oauth: curtin in-target – yum install -y python-oauthlib python-oauth liboauth

We did have an issue where the oauth package went missing in January, that has been fixed.

@tmartins can you make sure your images are in sync? /var/lib/maas/boot-resources/current/centos/amd64/generic/centos70/daily/root-tgz should have a SHA256SUM of dcbf759f0fae1623c40ebc8dcf1e83a6f83c35eabf0b7cf30932d3db9baaf81d for the latest image.

Yep, that’s the exactly sha256sum that I have! I installed this MaaS few days ago, images sync everyday.

But it still fails.

I’ll try that curtin thing but, I hope that it doesn’t break Ubuntu deployments.

I honestly don’t know which file exactly to add that “in-target” line.

Ok, found the “curtin_userdata_centos” and added the following line at the end of it:

10_install_oauth: curtin in-target – yum install -y python-oauthlib python-oauth liboauth

Testing it now!

No, didn’t worked… Do I have to restart services after updating the curtin* files?

I manage to record a video and here is a screenshot in the moment that it fails:


I restored the original curtin_userdata_centos file before.

It’s trying to connect to the yum repos via IPv6! I’m sure that I don’t have IPv6 (no gateway6, no RA, no DHCPv6, just Link-Local “fe80…”).

No idea why CentOS is trying to reach the Internet6 while there is no signal of IPV6 in my lab.

AHA! Some progress!

I changed the MaaS’ PXE Boot network for the CentOS VM, from AutoAssign, to DHCP, then, it worked!

Well, almost…

At least now I can see CentOS login!

But, on MaaS, it shows as “Failed deployment”… Work in this next problem now!

Somehow, after trying and trying… It’s working now!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.