Can't get VM nor Bare Metal Provisioned from MAAS

I’m running MAAS (MAAS version: 2.9.1 (9153-g.66318f531)) on a XCP-ng VM. I can access dashboard and everything appears to work there.

May be related : cloud-init: Did not find any data sources
It appears they had same error, something to do with LXC. Don’t know if this applies to xcp-ng.

I’m stuck at the next stage, which is provisioning a bare metal machine or a VM created on XCP-ng.

All attempts are made using ga-20.04 LTS kernel.

On the Bare Metal (Dell R415):
Settings in MAAS: provided MAC address, provided iDRAC6 address, user name, password, ip.
I can’t get it to start an install. MAAS boots up the server, but then it goes to “No bootable devices found”. I tried to press PXE Boot during start up on the bare metal, and it didn’t change a thing.

On the VM:
Settings in MAAS : provided MAC address, power type “manual”.

It would start the install, get to the very last stage of cloud-init and fail, it skims pretty fast but from what I could see, it couldn’t start openssh. If I press “enter” on the console, it loads up login on the command line. I cannot ssh into it though.

This is where I think some of the issue may lie:
Local network, Gateway (my router)
I have enabled DHCP on MAAS and created a IP reservation range. (
I’m wondering if it’s because I haven’t separated out my networks and running everything on my home network.

Any tips or information I can provide to get this working? I was really hoping to try running openstack &/or kubernetes with Juju + MAAS.

@dperkunas, it might work, but it isn’t supported. we don’t have a way to control power for Xen VMs. even if you manually control the power or use the webhook, you still may need a different kernel. as a reference point, Xen PV used to require a special kernel – which we don’t provide in MAAS.

maybe another user on the channel can help?

@billwear Thank you for the reply. It led me down another path of googling and searching the forums till I found the solution.

The solution was to have a DNS server set (to MAAS server itself) inside the Fabric under the Subnets tab.

The other REALLY important thing I didn’t know, and this is my noobiness, is that the IPMI password cannot have any special characters, like !'s or #'s.

XCP-ng VM was able to install fine after that. Did testing with virtualbox too, and virtualbox needed the extension bundle installed for it to install onto those VM’s.

As for the R415, in the bios I needed to change the nic from “enabled” to “enabled with PXE boot”, didn’t realize that had to be explicitly said. Doubt anyone would’ve found that because they would’ve assumed I had already set that. This one drove me mad as MAAS would boot up the server, thinking PXE boot was working, but it wasn’t going into pxe boot after powering up.

Thank you for the reply!

1 Like

@dperkunas, glad you found it. and very impressed with your network skills. really nice work!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.