Boot sequence


#1

Hi all,
It seems that after the deployment of a machine the boot sequence order is changed to default the OS. However if you want to commission again a system (ex. when a raid configuration change) it fails as it does not go to PXE boot. Is there an option to enforce during the commissioning a net boot ? Otherwise the admin has to enter those usually awful VGA consoles :slight_smile:


#2

What power driver are you using to control the machine?


#3

Additionally to that, is this EFI or Legacy ?

To provide more info, on Legacy systems MAAS doesn’t change the bootorder of the system in the BIOS/BMC. MAAS relies in it for the boot order.

For EFI systems, this works a little different. By default, when grub is installed onto the boot disk, it changes the boot order to boot from disk. However, curtin deals with that by ensuring that the boot order is changed back to boot from the network first. Curtin relies on BootCurrent (PXE) being set by the firmware. If it is not being set, then curtin cannot correctly set the bootorder and you would have behavior as you see. This would be a firmware issue: https://bugs.launchpad.net/curtin/+bug/1789650/comments/12


#4

I am using the IPMI driver


#5

It is EFI but I cannot tell for sure if the firmware supports BootCurrent. I suppose it does because I do see entries in the bootloader and in the first deployment the boot order changes to have the OS as the first entry.

A quick’n’dirty workaround would be somehow to be able to update MaaS with hardware info.


#6

And are you setting the Power boot type to EFI or Auto?


#7

Power type: IPMI
Power driver: LAN_2_0 [IPMI 2.0]
Power boot type: EFI boot


#8

Every time a machine is deployed (or commissioned, rescue mode, hardware testing, etc) MAAS tells the BMC to boot from PXE. On each start request MAAS tells the BMC to set the boot order to PXE for the next boot.

Based on the power parameters you’ve provided, MAAS will tell the BMC to boot PXE in EFI mode. In other words, on deployment, MAAS will first configure the BMC to PXE boot in EFI mode for the next boot, so that the machine always PXE boots.

Given that this is not working as expected, and the likely fact that BootCurrent is not being set, I would think this is a firmware issue. Just in case, can you provide:

  1. The installation log (which should show us the BootCurrent and boot ordering)
  2. Check the logs for something like “Failed to change the boot order to PXE”