Assigning a static IP address to deployed machine fails

When I have a deployed machine I don’t seem to be able to assign a static IP address to the machine.
I put it in the broken state, change the IP address and set it back to fixed, but I can’t do this. I get the message the machine hasn’t been commissioned. I have tried it about ten times now and it’s not working. Anybody got an idea what I am doing wrong?
Rebooting the machine doesn’t help, because it will still have the same IP address.
I wonder if it has something to do with my subnet being managed or unmanaged. I get the idea it is managed. After all MAAS is running the DHCP server on that subnet.
I guess in that case the static IP address should be outside the reserved range.

hi, @wenslauw,

We need a little more information to go on, if you don’t mind.

Can you please Identify your version and build?

We need to know the version and build (and packaging format) that you’re running.

If you’re using a snap

If you’re using a snap, execute snap listmaas at the command line, which will return some lines like this:

Name  Version                       Rev    Tracking     Publisher   Notes
maas  3.0.0~beta2-9796-g.2182ab55f  13292  latest/edge  canonical✓  -

Please add the output of that command to a comment on this post.

If you’re using a Debian package

If you’re using a deb, execute apt list maas at the command line, and enter whatever it returns into a comment to this post, as in the snap example above.

Using CLI, UI, or API?

Next, you’ll need to specify which interface you’re using, and generally what command(s) you were attempting.

Explain what happens

Being as concise and specific as you can, please explain a little more about what seemed to go wrong. You mentioned that you deployed a machine, marked it broken, changed the IP addres, and tried to set it back to fixed, but this didn’t work. I’m not sure changing the IP address of a deployed machine is going to work, but tell us what you did.

Explain how to reproduce your issue

In addition to the explanation above, you should create a step-by-step list of what you did to reproduce the problem.

Take relevant screenshots

If you think it will help – especially when using the UI – try and capture screenshots of any unexpected results or ambiguous actions. Your goal isn’t to document your experience in pictures, but to provide a visual reference where verbal descriptions fall short. Name these so you can sync them with your explanation (e.g., “screenshot-1”). You should be able to upload them to the comment.

Locate and capture logfiles

If at all possible, capture at least the following logfiles, for the time period surrounding your error situation:

  1. maas.log
  2. regiond.log
  3. rackd.log
  4. the rsyslog file of the affected machine(s), if it exists.

On snap, these files are located as follows:

  • /var/snap/maas/common/log/maas.log
  • /var/snap/maas/common/log/regiond.log
  • /var/snap/maas/common/log/rackd.log
  • /var/snap/maas/common/log/rsyslog/$MACHINE_NAME/$RELEVANT_DATE/messages

If you’re using packages, you’ll find the files in these locations:

  • /var/log/maas/maas.log
  • /var/log/maas/regiond.log
  • /var/log/maas/rackd.log
  • /var/log/maas/rsyslog/$MACHINE_NAME/$RELEVANT_DATE/messages

Ideally, you’d want to put these in a pastebin and link the pastebin location in your comment.

Thanks for this. We’ll need this additional information in order to try and figure out what’s going on.