Addin default search domain - Bionic


#1

Hi guys,

I have asked this question on the Juju Discourse forum but realized that netplan might be controlled from MAAS initally and only copied/modified by Juju.

I am having issues deploying a Openstack Bionic-Rocky cloud. All the nodes are complaining about not able to resolve the hostnames of its peers.

So i thought i could work around this by pushing a juju-run command with some sed magic. But that didn’t work so great.

My question is if there is a way to instruct MAAS to deploy the machine with a default search the same way you provide the default nameserver today?
image

Best regards
Emil


#2

Hi there,

It is not yet possible to overwrite the search domain. See https://bugs.launchpad.net/maas/+bug/1719473.

That said, if you are using LXD containers, these should be getting the config from MAAS< which should actually include the DNS config.

Can you please expand on how this is all configured? Are the LXD containers in a subnet that MAAS knows about? Have you investigated DNS issues in general?


#3

Hi,

So if i understand correctly the LXD containers rely on the host to have a dns-search, and the hosts rely on the MAAS controller.
I think i removed the search setting in netplan on my Maas by accident. I will redeploy my cluster with these changes to see if works better.

Thank you for clarifying :slight_smile: