3.3.0~rc1 - Deploy with "Register as MAAS KVM Host" hangs in "Rebooting" and finally times out

Hi, I’m running into an issue where deploying a machine with the “Register as MAAS KVM Host” option enabled. When doing this the final rebooting phase hangs until it times out. The machine is actually deployed and running but something prevents MAAS from detecting this. I’ve tried using 22.04 and 20.04 as deployment targets. The installation log doesn’t show anything failing.

I saw this reported as a bug earlier but it’s marked as fixed in 3.3-beta. Is this still a but or am I doing something wrong. Any ideas?


MAAS Version: 3.3.0~rc1-13127-g.e6737625f


Hi @jterrell , thanks for your report.

Please note this fix is related to the last release of cloud-init 22.4.2, so it’s important to be sure you are using the latest version of ubuntu images for 20.04 and 22.04 (currently, https://images.maas.io/ephemeral-v3/stable/focal/amd64/20221212/ )

And also could help to test the latest version of maas 3.3 currently in 3.3/edge 3.3.0~rc2-13138-g.bfa9e2d07.

Please, tell us if your tests succeed after these checks.

I believe I’m using the latest LTS of 22.04 and 20.04 (They’re syncing daily). Is there a way to verify the installed images?

I’ll try the 3.3/edge build.



Also, using the latest 3.3/edge build has the same behavior. I tried on two different physical machines, one with 20.04 LTS and one with 22.04 LTS.

BTW, the latest 3.3/edge build in snap is 3.3.0~rc2-13138-g.bfa9e2d07 (which is what I used above).

May you check the rsyslog messages of those installations, looking for which version of cloud-init is used?
for example: 2022-12-12T19:31:15+00:00 [...]: Cloud-init v. 22.4.2-0ubuntu0~20.04.1 running 'init-local' at Mon, 12 Dec 2022 19:31:11 +0000. Up 30.33 seconds.

To find those logs, this is useful: https://maas.io/docs/how-to-work-with-log-files#heading--path

Installing 22.04, cloud-init shows up in syslog as:

syslog:Jan 3 22:23:27 DL380-1 cloud-init[1814]: Cloud-init v. 22.4.2-0ubuntu0~22.04.1 finished at Tue, 03 Jan 2023 22:23:27 +0000. Datasource DataSourceMAA

Same behavior here, this is definitely a bug. Opened a support case for this one on canonical side, could be reproduced yet no solution available.

As a workaround you can add the KVM host manually after rebooting the host. From the UI entering the KVM host ip and executing the suggested command to accept the key. This will then make the deployment successful and one can start to deploy KVM machines.

1 Like

Also seeing this behavior:
MAAS: 3.3.0~rc1
Cloud-init: v. 22.4.2-0ubuntu0~20.04.2

@jordangarside Have you also seen this same behaviour on rc2 and with cloud init updated?

Tried again on 3.3.0~rc2-13143-g.398fe9a46 and still saw the same behavior, Cloud-init v. 22.4.2-0ubuntu0~22.04.1 according to the logs (is there a newer version?).

AFAIK that is the most up-to-date version of Cloud-init. Could you file a bug report and attach any relevant logs from attempting deploy up to the timeout?

I messed around with some of firewall settings today and now it actually is working for me on RC2, sorry about that.
I may try to downgrade to RC1 tomorrow and see if I was still having an issue there are not.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.