[2.6] Solved deploy fail, Failed to login to virsh console

I have already setup MAAS on one host. I am trying to deploy to another host, ubuntu 18.04 LTS with KVM host support, but it always ends with “Failed deployment”.

Event log had two errors:

Mon, 23 Sep. 2019 09:52:26 - Marking node failed - Internal error while creating KVM pod. (See regiond.log for details.)
Mon, 23 Sep. 2019 09:31:34 - Script result lookup or storage error - driven-cod.maas(kf6ybr): commissioning script '99-maas-03-network-interfaces' failed during post-processin

My controller regiond.log had this error:

2019-09-23 09:52:26 metadataserver.api_twisted: [critical] Exception while saving pod form.
        Traceback (most recent call last):
          File "/usr/lib/python3/dist-packages/maasserver/utils/orm.py", line 756, in call_within_transaction
            return func_outside_txn(*args, **kwargs)
          File "/usr/lib/python3/dist-packages/maasserver/utils/orm.py", line 563, in retrier
            return func(*args, **kwargs)
          File "/usr/lib/python3.6/contextlib.py", line 52, in inner
            return func(*args, **kwds)
          File "/usr/lib/python3/dist-packages/metadataserver/api_twisted.py", line 390, in _processMessage
        --- <exception caught here> ---
          File "/usr/lib/python3/dist-packages/metadataserver/api_twisted.py", line 213, in _create_pod_for_deployment
          File "/usr/lib/python3/dist-packages/maasserver/forms/pods.py", line 282, in save
            return self.discover_and_sync_pod()
          File "/usr/lib/python3/dist-packages/maasserver/forms/pods.py", line 359, in discover_and_sync_pod
            raise PodProblem(str(error))
        maasserver.exceptions.PodProblem: Failed talking to pod: Failed to login to virsh console.

I can SSH into the machine which the deploy failed. KVM is installed, and there is a user named virsh. I don’t know the password as it is setup by MAAS. I checked the /etc/shadow file and theres a password there. I can’t register it in PODS cause i dont know the unencrypted pass.

However, why is virsh failing to login to console?

The host machine interface setup has the following details:

  • br-eno1, bridge, DHCP externally assigned with internet access, no vlan tag
  • br-eno2.100, bridge, MAAS managed DHCP, vlan tag 100

I was able to solve this.

For some reason the Pod is registered and using the virsh address of the untagged vlan. My maas controller did not have a IP address on vlan with no tags, it only has an address on vlan 100.

I added an extra untagged vlan IP address to the maas controller, then released, acquired, deployed and it’s all worked as intended.

The question now is, when deploying machines and checking “Register as MAAS KVM host”, how does maas select a virsh ip address? is it just the first one it finds? or is it the untagged vlan? can we configure it somehow?

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.