Server reboots as soon as it loads initrd from maas over PXE

I’m running into an issue where we have hundreds of a specific machine type using a supermicro X11SSE-F motherboards (this is a blade board), the two I picked to test out on maas both exhibit the same issue where they immediately reboot when being commissioned right after the pxeboot process loads the initrd. Using MaaS 2.6.2 from PPA

Not sure where to go from here, aside from looking for bios updates.

Do they reboot or power off? Are they marked Commissioned when done?

The normal commissioning sequence is to boot into the ephemeral commissioning environment, collect a bunch of info, and then power off. You can tell it to remain on after commissioning if you need to debug a commissioning failure or just want to test things in the commissioning environment.

The instances IMMEDIATELY reboot as soon as you see the initrd message while watching the machine’s IPMI console. They don’t boot the kernel up and run as expected. Switching to using 20.04 for commissioning allows the machines to boot, so something is definitely not working with the 18.04 images for commissioning and the supermicro X11SSE-F motherboard.

I just noticed this exact same behavior when trying to deploy a system with a SuperMicro X11SSH-LN4F motherboard. (The system had been deployed for several months, and this was the first deployment in a long time.)

I have not yet tried switching the default commissioning version to 20.04 (we needed to get the system running quickly, so we allocated it in maas, disabled PXE boot, and did an old fashioned physical media install).

After you commission your machine with 20.04, are you able to deploy it with 18.04, or does it simply fail to boot 18.04? If the latter, perhaps this is a regression in the Ubuntu 18.04 kernel.