EFI Stub ERROR kernel image not aligned on 64K boundary

Hello all,
I tried MaaS PXE netbooting to commission my Pi cluster and I keep getting this error. I am running latest version of UEFI RPI 4 USB boot v1.33 but this still didn’t solve this issue. Any ideas as to how I can proceed? This seems like a very low level problem which I personally am not too familiar with as I am getting started on this journey.

Hi there, it’d be useful to understand what image MAAS is trying to serve for boot. In order to do so, can you please provide the regiond.log and rackd.log? If you’re using the apt package, those are found in /var/log/maas/ and /var/snap/maas/common/log for the snap installation.

Hey there, Thanks for the pointer, Here are the requested logs.

In the process of copying these I received cat: write error: Connection reset by peer so kindly let me know if any information is missing and I can create a zip file of the logs instead.

@ryzengrind, yeah, i can’t see the log files. wanna try a zip?

Hey @billwear, thanks for your patience, I got caught up with final exams and whatnot and didn’t get a chance to play around again till now.

I’ve attached the log files from the rack and region controllers below.

Incase this link goes down, I’ve added a second link as backup.

I am in the process of attempting to deploy Talos OS and Nix OS on some devices in my cluster for further experimentation and did re-encounter this error while trying to recommission my devices so any insight would be greatly appreciated.

I’m having the same error and there isn’t anything in my logs showing any errors. It seems to be something to do with Raspberry Pi and the kernel itself. I tried running MaaS from a Pi and an amd64 system but had the same results. MaaS works fine with Virsh, LXD, and even amd64 systems. It seems the kernel used for arm64 is the issue in my case. It occurs when attempting to boot an arm64 virtual machine as well.

The issue might be related to the version of grub that MAAS is using.
Here is a bug that was recently reported.

At the moment we are waiting for the fix to be backported to focal. Once it is done we will update the bootloader image

1 Like


Grub 2.06 is now available in the candidate stream https://images.maas.io/ephemeral-v3/candidate/bootloaders/uefi/amd64/20230203.0/

Can you please check if the new version fixes the issue?

In order to test the candidate, you need to change the stream, here is the doc to help you.

Once it’s confirmed that it works for you, we can promote a new image to the stable.

@ryzengrind, did you try @troyanov’s suggestion above?

I just added a new amd64 intel Server S2600GZ to my hardware stack.

I will test out the above mentioned solution for the arm64 devices and confirm whether it solved the issue or not soon. Thank you

1 Like